Инструменты пользователя

Инструменты сайта


doc:doclist:change_pack

Различия

Здесь показаны различия между двумя версиями данной страницы.

Ссылка на это сравнение

Следующая версия
Предыдущая версия
doc:doclist:change_pack [2019/03/01 11:04]
katya создано
doc:doclist:change_pack [2019/07/10 17:26] (текущий)
katya
Строка 1: Строка 1:
-====Установка/​замена (install/​reinstall) PACK====+======Установка/​замена (install/​reinstall) PACK====== 
 + 
 +Software pack для KEIL MDK 5 для МК 1986ВЕ9х,​ 1Т, 3Т, 4У 
 + 
 +Перед началом работы в среде программирования KEIL необходимо установить PACK. Скачивать PACK рекомендуется только с официального сайта компании "​Миландр"​ [[http://​https://​ic.milandr.ru/​upload/​iblock/​b7c/​b7cac540c48efc2c8ca688318a1ddd18.rar|pack]]. ​  
 + 
 +<note important>​Библиотека SPL предназначена для оказания технической помощи в освоении и демонстрации возможностей микроконтроллера и призвана ускорить процесс освоения микросхемы пользователем. Компания «Миландр» не возражает против частичного или полного использования библиотеки в проектах пользователя,​ но без каких-либо дополнительных гарантий и обязательств со стороны компании "​Миландр"​ по корректности библиотеки. Поэтому всю полноту ответственности за конечное качество программного обеспечения несет разработчик,​ применяющий библиотеку.</​note>​ 
 + 
 +Если PACK был ранее установлен (например,​ 1.4), но вышла более новая версия (1.51), то 
 + 
 +  * Cкачать PACK. 
 +  * Сохранить его в папке со средой KEIL. 
 +  * Запустить установку,​ кликнув на PACK 2 раза. 
 + 
 +{{:​doc:​doclist:​start_inst1.png?​nolink&​600|}} 
 + 
 +{{:​doc:​doclist:​start_inst2.png?​nolink&​600|}} 
 +  * Запустить KEIL.  
 +  * Зайти во вкладку PACK INSTALLER 
 + 
 +{{:​doc:​doclist:​pack_inst3.png?​nolink&​600|}} 
 +  * Кликнуть на 1.5 ”Remove”,​ чтобы у всех ранее установленных паков было “Unpack”,​ а у 1.51 “Remove” 
 +{{ :​doc:​doclist:​pack_inst4.png?​nolink |}} 
 +  * Закрыть Pack Installer 
 +  * В основном окне KEIL появится сообщение «Software Packs has been modified. Reload Packs?» Выбрать «Да» 
 +  * Открыть любой ранее созданный проект. 
 +  * Скомпилировать проект. 
 + 
 +При переходе с версии PACK 1.5 на 1.51 (и старше) никаких дополнительных действий не требуется.  
 +Файлы, в которых были проведены изменения,​ помечены восклицательным знаком. 
 +<note warning>​Если версия PACK была ниже 1.5, то при компиляции проекта могут возникать ошибки,​ связанные с тем, что какие-то файлы не находятся. Тогда нужно зайти во вкладку Manage Run-Time Environment. Для тех компонентов,​ которые выделены красным,​ развернуть выпадающее меню и выбрать файлы (драйверы),​ соответствующие новой версии пака, переместив выделяющий маркер.</​note> ​  
 +После скомпилировать проект еще раз. 
 + 
  
  
doc/doclist/change_pack.1551427470.txt.gz · Последние изменения: 2019/03/01 11:04 — katya